What’s Vulnerable › Vulnerabilities
CVE-2026-77620: Vector: Unauthenticated denial of service in the `logstash` source via nested compressed frames (stack exhaustion and decompression amplification).
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-24
- Weakness: CWE-409
Description
Vector is a high-performance observability data pipeline. From 0.15.0 until 0.57.0, the logstash source feeds each decompressed frame back into its decoder without limiting nested compression depth. An unauthenticated remote peer that can reach the default 0.0.0.0:5044 listener can send many nested compressed frames, causing recursive decoding that exhausts the worker thread stack and aborts the process. The same nested construction amplifies decompressed input, and process termination can halt log ingestion for every tenant on a shared pipeline. This issue is fixed in version 0.57.0.
Affected products
- vectordotdev vector: from 0.15.0, < 0.57.0
References
- https://github.com/vectordotdev/vector/commit/57fed991083c9a43d5fda2d5b3bf4718aedf6526
- https://github.com/vectordotdev/vector/pull/25825
- https://github.com/vectordotdev/vector/releases/tag/v0.57.0
- https://github.com/vectordotdev/vector/security/advisories/GHSA-qp6f-fpfx-4gg6
Get alerted when CVE-2026-77620 or the next vulnerability affects your stack