What’s Vulnerable › Vulnerabilities
CVE-2026-7768: @fastify/accepts-serializer vulnerable to Denial of Service via Unbounded Accept Header Cache Growth
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-06-17
- Weakness: CWE-770
Description
@fastify/accepts-serializer cached serializer-selection results keyed by the request Accept header without a size limit or eviction policy. A remote unauthenticated client could send many distinct but matching Accept header variants to make the cache grow unbounded, eventually exhausting the Node.js heap and crashing the process. Versions <= 6.0.3 are affected. Update to 6.0.4 or later, which bounds the cache via an LRU with a default size of 100 entries, configurable through the new cacheSize plugin option.
Affected products
- @fastify/accepts-serializer: before 6.0.4 — fixed in 6.0.4
How to fix
Upgrade to a fixed version: @fastify/accepts-serializer 6.0.4. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify-accepts-serializer/security/advisories/GHSA-qxhc-wx3p-2wmg
Get alerted when CVE-2026-7768 or the next vulnerability affects your stack