What’s Vulnerable › Vulnerabilities
CVE-2026-77704: Amelia 1.2.32 - 2.4.8 - Amelia Customer+ Appointment Status Update and Self-Approval
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-29 · updated 2026-08-31
- Weakness: CWE-863
Description
The Booking for Appointments and Events Calendar WordPress plugin before 2.4.9 does not check that a user holds the required capability before letting them change an appointment's status, allowing customers to set arbitrary statuses on appointments they are booked on, including approving their own bookings that were left awaiting approval and overwriting another customer's booking status on a shared appointment.
Affected products
- Booking for Appointments and Events Calendar: from 1.2.32 before 2.4.9 — fixed in 2.4.9
How to fix
Upgrade to a fixed version: Booking for Appointments and Events Calendar 2.4.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-77704 or the next vulnerability affects your stack