What’s Vulnerable › Vulnerabilities
CVE-2026-7771: IBM® Db2® is vulnerable to a trap when compiling specially crafted statements containing subqueries could lead to a denial of service
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-835
Description
IBM Db2 11.5.0 through 11.5.9, and 12.1.0 through 12.1.4 is vulnerable to a trap when compiling a specially crafted statements containing subqueries could lead to a denial of service.
Affected products
- IBM Db2 for Linux, UNIX and Windows: from 11.5.0 through 11.5.9; from 12.1.0 before 12.1.5 — fixed in 12.1.5
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 12.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-7771 or the next vulnerability affects your stack