What’s Vulnerable › Vulnerabilities
CVE-2026-7776: Boundary Workers Vulnerable to Denial of Service During TLS Handshake
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-770
Description
Boundary Community Edition and Boundary Enterprise (“Boundary”) workers are vulnerable to a denial-of-service condition during node enrollment TLS handshakes. An attacker with network access to the worker authentication listener may open a connection and delay or withhold the client certificate during the TLS handshake, causing worker connection handling to block. This may prevent legitimate worker connections from being accepted or routed. This vulnerability, CVE-2026-7776, is fixed in Boundary 0.21.3, 0.20.3, 0.19.5.
Affected products
- HashiCorp Boundary: from 0.9.0 before 0.21.3 — fixed in 0.21.3
- HashiCorp Boundary Enterprise: from 0.9.0 before 0.21.3 — fixed in 0.21.3
How to fix
Upgrade to a fixed version: HashiCorp Boundary 0.21.3; HashiCorp Boundary Enterprise 0.21.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-7776 or the next vulnerability affects your stack