What’s Vulnerable › Vulnerabilities
CVE-2026-77765: Better Payment < 2.3.4 - Unauthenticated Payment Amount Manipulation
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-284
Description
The Better Payment WordPress plugin before 2.3.4 does not validate the submitted payment amount server-side against the merchant's configured fixed price before building the gateway charge, allowing unauthenticated users to pay an arbitrary reduced amount for a fixed-price item.
Affected products
- Better Payment: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Better Payment 2.3.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-77765 or the next vulnerability affects your stack