What’s Vulnerable › Vulnerabilities
CVE-2026-77792: RegistrationMagic < 6.0.9.9 - Unauthenticated Stored XSS via Rating Field
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-79
Description
The RegistrationMagic WordPress plugin before 6.0.9.9 does not escape a registration form field value before outputting it in an HTML attribute on an administrative page, allowing unauthenticated users to perform Stored Cross-Site Scripting attacks against high privilege users such as admin.
Affected products
- Metagauss RegistrationMagic: before 6.0.9.9 — fixed in 6.0.9.9
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 6.0.9.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-77792 or the next vulnerability affects your stack