What’s Vulnerable › Vulnerabilities
CVE-2026-77806
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-21 · updated 2026-10-15
- Weakness: CWE-94
Description
SPIP before 4.4.21 allows unauthenticated remote attackers to execute arbitrary code, as exploited in the wild in August 2026. This is related to code injection via an X-Spip-Filtre HTTP request header that is mishandled by analyse_resultat_skel.
Affected products
- SPIP: before 4.4.21 — fixed in 4.4.21
How to fix
Upgrade to a fixed version: SPIP 4.4.21. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/Mise-a-jour-critique-de-securite-sortie-de-SPIP-4-4-21.html
- https://github.com/rapid7/metasploit-framework/pull/21790
- https://github.com/rapid7/metasploit-framework/pull/21790#issuecomment-5368038123
- https://github.com/rapid7/metasploit-framework/pull/21790/commits/b16eca819abb8f1401f21d115e71e3dfc67b847c
Get alerted when CVE-2026-77806 or the next vulnerability affects your stack