What’s Vulnerable › Vulnerabilities
CVE-2026-77811: Stored Cross-Site Scripting via Integration Template Asset in OpenSearch Dashboards
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-14
- Weakness: CWE-79
Description
Improper input validation in the dashboards-observability plugin in OpenSearch Dashboards allows a remote authenticated user with write permissions to OpenSearch Dashboards saved objects to execute arbitrary JavaScript in the context of other users' browser sessions by uploading a saved asset with arbitrary web content.
Affected products
- OpenSearch Dashboards dashboards-observability plugin: before 3.4; before 2.19.6 — fixed in 2.19.6, 3.4
How to fix
Upgrade to a fixed version: OpenSearch Dashboards dashboards-observability plugin 2.19.6, 3.4. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-088-aws/
- https://github.com/opensearch-project/dashboards-observability/security/advisories/GHSA-rmqx-r3wm-3px5
- https://opensearch.org/artifacts/by-version/#release-2-19-6
- https://opensearch.org/artifacts/by-version/#release-3-4-0
Get alerted when CVE-2026-77811 or the next vulnerability affects your stack