What’s Vulnerable › Vulnerabilities
CVE-2026-77883: Apache Syncope: Information disclosure via one-hop JEXL navigation past the JexlContextBuilder name denylist
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-14
- Weakness: CWE-202
Description
Exposure of sensitive information through data queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access LinkedAccount's (if present) or Manager's (if defined) sensitive information, possibly including hashed credentials. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Affected products
- Apache Software Foundation Apache Syncope: from 3.0.0-M0 through 3.0.16; from 4.0.0-M0 through 4.0.7; from 4.1.0-M0 through 4.1.2
References
- https://lists.apache.org/thread/oshwdz2k4cl3042y39zq0yl4qkxbd83p
- http://www.openwall.com/lists/oss-security/2026/09/14/17
Get alerted when CVE-2026-77883 or the next vulnerability affects your stack