What’s Vulnerable › Vulnerabilities
CVE-2026-78008: Fireware OS Authenticated Buffer Overflow in wgagent
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-03
- Weakness: CWE-787
Description
A buffer overflow vulnerability in the WatchGuard Fireware OS Management Web UI allows an authenticated administrator with network access to cause a denial of service (DoS) condition or potentially execute arbitrary code by sending specially crafted network traffic.
Affected products
- WatchGuard Fireware OS: from 2025.0 before 2026.2.2; from 12.0 before 12.12.2; from 2026.3 before 2026.3.1; from 12.0 before 12.5.20 — fixed in 12.12.2, 12.5.20, 2026.2.2, 2026.3.1
How to fix
Upgrade to a fixed version: WatchGuard Fireware OS 12.12.2, 12.5.20, 2026.2.2, 2026.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-78008 or the next vulnerability affects your stack