What’s Vulnerable › Vulnerabilities
CVE-2026-7808: justhtml before 1.16.0 Multiple Security Issues via Sanitization
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-23 · updated 2026-10-12
- Weakness: CWE-20
Description
justhtml before 1.16.0 contains multiple HTML sanitization bypass issues that can allow active/dangerous content (e.g., script or style) to survive sanitization, potentially leading to cross-site scripting. The issues primarily affect advanced usage rather than the default JustHTML(..., sanitize=True) path for ordinary parsed HTML: mutating or reusing sanitization policy objects (including exported defaults) could weaken later sanitization; programmatic DOM input to sanitize()/sanitize_dom() could miss mixed-case tag names (e.g., ScRiPt, StYlE); crafted programmatic doctype names could serialize into active markup; and custom policies preserving SVG or MathML could allow animation elements, presentation attributes with external url(...) references, or DOM trees mislabeled as namespace="html" to bypass foreign-content checks. Fixed in 1.16.0.
Affected products
- EmilStenstrom justhtml: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: EmilStenstrom justhtml 1.16.0. Check the vendor advisory for mitigations.
References
- https://github.com/EmilStenstrom/justhtml/security/advisories/GHSA-4p64-v8f5-r2gx
- https://www.vulncheck.com/advisories/justhtml-before-multiple-security-issues-via-sanitization
Get alerted when CVE-2026-7808 or the next vulnerability affects your stack