What’s Vulnerable › Vulnerabilities

CVE-2026-78124

Description

strongSwan 5.0.2 through 6.0.7 allows PKCS#7 certificate enumeration in the openssl plugin that leads to a lack of release of memory after its effective lifetime.

Affected products

How to fix

Upgrade to a fixed version: strongSwan 6.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-78124 or the next vulnerability affects your stack