What’s Vulnerable › Vulnerabilities
CVE-2026-7814: pgAdmin 4: Stored XSS via crafted PostgreSQL object names in Browser Tree and Explain Visualizer
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-79
Description
Stored cross-site scripting (XSS) vulnerability in pgAdmin 4 Browser Tree and Explain Visualizer modules. User-controlled PostgreSQL object names (database, schema, table, column, etc.) were assigned to DOM elements via innerHTML, allowing crafted object names containing HTML markup to execute attacker-supplied JavaScript in the browser of any pgAdmin user who navigated to or executed EXPLAIN over the malicious object. Fix replaces innerHTML with textContent. This issue affects pgAdmin 4: before 9.15.
Affected products
- pgadmin.org pgAdmin 4: from 6.9 before 9.15 — fixed in 9.15
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.15. Check the vendor advisory for mitigations.
References
- https://github.com/pgadmin-org/pgadmin4/pull/9865
- https://github.com/pgadmin-org/pgadmin4/issues/9865
Get alerted when CVE-2026-7814 or the next vulnerability affects your stack