What’s Vulnerable › Vulnerabilities
CVE-2026-7815: pgAdmin 4: SQL injection in Maintenance tool option values leading to remote code execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-89
Description
SQL injection vulnerability in pgAdmin 4 Maintenance Tool. Four user-supplied JSON fields (buffer_usage_limit, vacuum_parallel, vacuum_index_cleanup, reindex_tablespace) were concatenated directly into the rendered VACUUM/ANALYZE/REINDEX command and passed to psql --command. An authenticated user with the tools_maintenance permission could break out of the option syntax and execute arbitrary SQL on the connected PostgreSQL server. The injected SQL could in turn invoke COPY ... TO PROGRAM to escalate to operating-system command execution on the database host. Fix introduces server-side allow-listing of all four fields and switches reindex_tablespace from manual quoting to the qtIdent filter. This issue affects pgAdmin 4: before 9.15.
Affected products
- pgadmin.org pgAdmin 4: from 7.6 before 9.15 — fixed in 9.15
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-7815 or the next vulnerability affects your stack