What’s Vulnerable › Vulnerabilities
CVE-2026-7816: pgAdmin 4: OS command injection in Import/Export query export via psql metacommand breakout
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-78
Description
OS command injection (CWE-78) vulnerability in pgAdmin 4 Import/Export query export. User-supplied input was interpolated directly into a psql \copy metacommand template without sanitization. An authenticated user could inject ") TO PROGRAM 'cmd'" to break out of the \copy (...) context and achieve arbitrary command execution on the pgAdmin server, or ") TO '/path'" for arbitrary file write. Additional fields (format, on_error, log_verbosity) were also raw-interpolated and exploitable. Fix adds a parens-balance parser modeled on psql's strtokx tokenizer, allow-lists format/on_error/log_verbosity, rejects null bytes in the query, and tightens type and gating checks. This issue affects pgAdmin 4: before 9.15.
Affected products
- pgadmin.org pgAdmin 4: from 9.4 before 9.15 — fixed in 9.15
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 9.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-7816 or the next vulnerability affects your stack