What’s Vulnerable › Vulnerabilities
CVE-2026-78222: NGINX ngx_http_js_module vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-02
- Weakness: CWE-476
Description
A vulnerability exists in NGINX JavaScript where a malformed HTTP response received by ngx.fetch() can crash an NGINX worker when trusted JavaScript reads Response.statusText. Exploitation requires control or influence over the fetched HTTP response. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX JavaScript: from 0.5.1 before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: F5 NGINX JavaScript 1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-78222 or the next vulnerability affects your stack