What’s Vulnerable › Vulnerabilities
CVE-2026-78243: Apache YuniKorn: LDAP Group provider panics on lowercase attribute name
- Severity: low (CVSS 2.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-07
- Weakness: CWE-248
Description
Apache YuniKorn 1.8.0 and later, if configured with the LDAP group resolver, crashes due to an out of bounds read processing group membership entries.If the LDAP server returns a group membership entry, memberOf attribute, for a user specified in the pod the server crashes if a membership record does not start with "CN=". This only affects install that have the non default LDAP group provider configured. Users are recommended to upgrade to version 1.10.0, which fixes this issue.
Affected products
- Apache Software Foundation Apache YuniKorn: from 1.8.0 before 1.10.0 — fixed in 1.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache YuniKorn 1.10.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/yz51lpj6k8q2hz7x2gjdpcrk44hdn25v
- http://www.openwall.com/lists/oss-security/2026/10/07/24
Get alerted when CVE-2026-78243 or the next vulnerability affects your stack