What’s Vulnerable › Vulnerabilities

CVE-2026-78252: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 15.3 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions, an authenticated user could have induced a targeted user to perform unintended state-changing HTTP requests due to improper sanitization of user-controlled data in the Markdown JSON table renderer.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.1.8, 19.2.6, 19.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-78252 or the next vulnerability affects your stack