What’s Vulnerable › Vulnerabilities
CVE-2026-78299
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-16
- Weakness: CWE-22
Description
In Eclipse Embedded CDT versions 6.0 to 6.7 if the CMSIS-Pack archive extracts a compromised CMSIS pack the archive extraction can extract files to locations outside of the pack, allowing writing of arbitrary files to other locations on disk.
Affected products
- Eclipse Foundation Eclipse Embedded CDT (C/C++ Development Tools): from 6.0.0 before 6.8.0 — fixed in 6.8.0
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Embedded CDT (C/C++ Development Tools) 6.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-embed-cdt/eclipse-plugins/security/advisories/GHSA-qch4-8rmp-mjx3
- https://gitlab.eclipse.org/security/vulnerability-reports/-/work_items/747
Get alerted when CVE-2026-78299 or the next vulnerability affects your stack