What’s Vulnerable › Vulnerabilities

CVE-2026-78335: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user holding a project-scoped fine-grained Personal Access Token to modify integrations belonging to a group outside the token's scope, due to incorrect authorization checks.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-78335 or the next vulnerability affects your stack