What’s Vulnerable › Vulnerabilities
CVE-2026-78414: Cross-site scripting in Nx Witness VMS Web Administration allows session token exfiltration via a rogue peer site name
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-12
- Weakness: CWE-79
Description
Cross-site scripting in the Web Administration interface of Network Optix Nx Witness VMS before version 6.1.3 on Linux, Windows and MacOS allows an adjacent-network attacker to execute arbitrary JavaScript in the browser of an authenticated administrator and steal the administrator's session token, resulting in Administrator Account Takeover. An attacker who controls an Nx server on the same network segment can set that server's site name to a script payload, which executes when an administrator opens the "Merge with Another Site" dialog and the site selection list is displayed.Solution: Update to Nx Witness VMS version 6.1.3 or later.
Affected products
- Network Optix Nx Witness VMS: before 6.1.3 — fixed in 6.1.3
How to fix
Upgrade to a fixed version: Network Optix Nx Witness VMS 6.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-78414 or the next vulnerability affects your stack