What’s Vulnerable › Vulnerabilities
CVE-2026-78587: Incorrect Authorization in Fleet Server Leading to Denial of Service of Agent Upload Operations
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-863
Description
Incorrect Authorization (CWE-863) in Fleet Server can lead to a denial of service of agent upload operations via Privilege Abuse (CAPEC-122). Fleet Server does not correctly verify session ownership during multi-part data upload operations, allowing any authenticated agent to interfere with the active upload sessions belonging to other enrolled agents.
Affected products
- Elastic Fleet Server: from 8.0.0 before 8.19.16; from 9.0.0 before 9.3.5; from 9.4.0 before 9.4.2 — fixed in 8.19.16, 9.3.5, 9.4.2
How to fix
Upgrade to a fixed version: Elastic Fleet Server 8.19.16, 9.3.5, 9.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-78587 or the next vulnerability affects your stack