What’s Vulnerable › Vulnerabilities
CVE-2026-78607: Missing Authorization in Elasticsearch Leading to Information Disclosure
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-02
- Weakness: CWE-862
Description
Missing Authorization (CWE-862) in the Elasticsearch custom inference service can lead to information disclosure via Privilege Abuse (CAPEC-122). A user holding only inference execution privileges could cause outbound inference traffic to be directed to a destination of their choosing and could cause administrator-provisioned credentials to be exposed.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.19; from 9.0.0 before 9.3.8; from 9.4.0 before 9.4.4; 9.5.0 — fixed in 8.19.19, 9.3.8, 9.4.4
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.19, 9.3.8, 9.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-78607 or the next vulnerability affects your stack