What’s Vulnerable › Vulnerabilities
CVE-2026-78609: Incorrect Authorization in Elastic Cloud on Kubernetes Leading to Unauthorized Modification of Data
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-04
- Weakness: CWE-863
Description
Incorrect Authorization (CWE-863) in Elastic Cloud on Kubernetes (ECK) can lead to unauthorized modification of data via Metadata Spoofing (CAPEC-690). An actor holding limited Kubernetes permissions confined to a single namespace could cause attacker-controlled certificate material to be included in the Elasticsearch client trust bundle managed by ECK in a separate namespace.
Affected products
- Elastic Cloud on Kubernetes: from 2.6.0 before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: Elastic Cloud on Kubernetes 3.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-78609 or the next vulnerability affects your stack