What’s Vulnerable › Vulnerabilities

CVE-2026-7866: Stack-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Buffers.

Description

Stack-based Buffer Overflow vulnerability in RTI Connext Professional (Core Libraries) allows Overflow Buffers. This issue affects Connext Professional: from 7.4.0 before 7.7.0.1, from 7.0.0 before 7.3.1.6, from 6.1.0 before 6.1.*, from 6.0.0 before 6.0.*, from 5.3.0 before 5.3.*, from 5.2.0 before 5.2.*, from 4.3x before 5.1.*.

Affected products

How to fix

Upgrade to a fixed version: RTI Connext Professional 7.3.1.6, 7.7.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-7866 or the next vulnerability affects your stack