What’s Vulnerable › Vulnerabilities
CVE-2026-78676: GitPython before 3.1.59 Remote Code Execution via Config Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-88
Description
GitPython before 3.1.59 fails to safely re-serialize multi-line git-config values during write operations, corrupting dormant quoted values into injected directives like core.hooksPath. Attackers can craft config files with embedded newlines that become live git directives after any unrelated GitPython config write, enabling arbitrary code execution via hook invocation.
Affected products
- gitpython-developers GitPython: before 3.1.59 — fixed in 3.1.59
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.59. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-284h-m62q-gf8w
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-config-injection
Get alerted when CVE-2026-78676 or the next vulnerability affects your stack