What’s Vulnerable › Vulnerabilities
CVE-2026-78678: GitPython before 3.1.59 Arbitrary File Read via Repo.blame()
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-88
Description
GitPython versions before 3.1.59 contain an incomplete denylist in the unsafe_git_revision_options guard that omits --contents and -S options, allowing attackers to read arbitrary files by passing these options to Repo.blame(). Attackers can supply revision values like --contents=/etc/passwd to leak file contents through the blame result returned to the caller.
Affected products
- gitpython-developers GitPython: before 3.1.59 — fixed in 3.1.59
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.59. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-5xxx-qhh7-9287
- https://www.vulncheck.com/advisories/gitpython-before-arbitrary-file-read-via-repo-blame
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-5xxx-qhh7-9287
Get alerted when CVE-2026-78678 or the next vulnerability affects your stack