What’s Vulnerable › Vulnerabilities
CVE-2026-78680: NLTK before 3.10.3 Arbitrary Code Execution via Graphviz dot Binary
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-426
Description
NLTK versions before 3.10.3 fail to use validated absolute paths when invoking the Graphviz dot binary in dependencygraph.dot2img and AlignedSent._repr_svg_, allowing attackers to execute arbitrary code by placing a malicious dot binary in the search path or current working directory. Attackers can exploit bare-name binary resolution on Windows via the current working directory or on Unix-like systems via relative PATH entries to execute their binary instead of the legitimate Graphviz tool.
Affected products
- nltk: before 3.10.3 — fixed in 3.10.3
How to fix
Upgrade to a fixed version: nltk 3.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-6hwm-xvph-95vm
- https://www.vulncheck.com/advisories/nltk-before-arbitrary-code-execution-via-graphviz-dot-binary
- https://github.com/nltk/nltk/security/advisories/GHSA-6hwm-xvph-95vm
Get alerted when CVE-2026-78680 or the next vulnerability affects your stack