What’s Vulnerable › Vulnerabilities
CVE-2026-78683: NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-502
Description
NLTK before 3.10.0 (affected versions <=3.9.4) contains an unsafe pickle deserialization vulnerability in the TransitionParser.parse() method (nltk/parse/transitionparser.py). The method calls pickle_load() with the default restricted=False, routing deserialization through WarningUnpickler, which does not override find_class() and therefore permits arbitrary class resolution. When an application loads an attacker-crafted model file, embedded pickle gadget chains execute arbitrary Python code with the privileges of the user running the application. NLTK provides a RestrictedUnpickler for safe deserialization, but it is not used by production code paths. Fixed in 3.10.0.
Affected products
- nltk: before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: nltk 3.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-rhp5-r9x4-f5g2
- https://www.vulncheck.com/advisories/nltk-before-remote-code-execution-via-unsafe-pickle-deserialization
- https://github.com/nltk/nltk/security/advisories/GHSA-rhp5-r9x4-f5g2
Get alerted when CVE-2026-78683 or the next vulnerability affects your stack