What’s Vulnerable › Vulnerabilities
CVE-2026-78684: vLLM before 0.27.0 Denial of Service via DeepStream Backend
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-09-29
- Weakness: CWE-400
Description
vLLM before 0.27.0 fails to properly classify DeepStream as a GPU backend and omits pixel-limit enforcement in its decode path. Unauthenticated attackers can activate DeepStream at request time to initialize the process-wide GPU decode pool and submit video that bypasses resource controls, causing partial denial of service for concurrent requests.
Affected products
- vllm-project vllm: before 0.27.0 — fixed in 0.27.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/e23b19309b8705b21c3b3ff4129c9974ba15a419
- https://github.com/vllm-project/vllm/security/advisories/GHSA-cqm8-jxg6-fqfq
- https://www.vulncheck.com/advisories/vllm-before-denial-of-service-via-deepstream-backend
Get alerted when CVE-2026-78684 or the next vulnerability affects your stack