What’s Vulnerable › Vulnerabilities
CVE-2026-79667: Ech0 before 4.4.3 Authentication Bypass via Scope Enforcement
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-08-31
- Weakness: CWE-285
Description
Ech0 version 4.3.4 and earlier fails to reliably enforce scoped access token (least-privilege) restrictions on several privileged admin routes. Multiple privileged endpoints (e.g., /api/inbox, /api/panel/comments, /api/backup/export) omit scope checks and authorize based only on the user's admin role, and the backup export handler discards token scope metadata entirely. An attacker holding a deliberately limited (low-scope) admin access token can reach broader privileged functionality than intended, including reading the inbox and exporting a full database backup ZIP archive. Fixed in 4.4.3.
Affected products
- lin-snow Ech0: before 4.4.3 — fixed in 4.4.3
How to fix
Upgrade to a fixed version: lin-snow Ech0 4.4.3. Check the vendor advisory for mitigations.
References
- https://github.com/lin-snow/Ech0/security/advisories/GHSA-4h9q-p5j4-xvvh
- https://www.vulncheck.com/advisories/ech0-before-authentication-bypass-via-scope-enforcement
- https://github.com/lin-snow/Ech0/security/advisories/GHSA-4h9q-p5j4-xvvh
Get alerted when CVE-2026-79667 or the next vulnerability affects your stack