What’s Vulnerable › Vulnerabilities
CVE-2026-79675: NLTK before 3.10.3 JVM Argument Injection via Per-Call Options
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-25 · updated 2026-09-01
- Weakness: CWE-88
Description
NLTK before 3.10.3 fails to validate JVM options passed through the per-call options parameter in the java() function, allowing attackers to inject dangerous JVM flags. Attackers can supply malicious options like -agentpath, -javaagent, or @argfile to Stanford wrapper classes to achieve arbitrary code execution.
Affected products
- nltk: before 3.10.3 — fixed in 3.10.3
How to fix
Upgrade to a fixed version: nltk 3.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/nltk/nltk/security/advisories/GHSA-m4rf-3fr8-xwx3
- https://www.vulncheck.com/advisories/nltk-before-jvm-argument-injection-via-per-call-options
Get alerted when CVE-2026-79675 or the next vulnerability affects your stack