What’s Vulnerable › Vulnerabilities
CVE-2026-79680: Authentication bypass vulnerability in the password authentication mechanism of the Qt VNC Server module
- Severity: medium (CVSS 4.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-24
- Weakness: CWE-288
Description
Authentication bypass vulnerability in the password authentication mechanism of the Qt VNC Server module. An attacker using a specially modified VNC client that violates the RFB protocol can bypass Qt VNC Server's password authentication and gain unauthorized remote access to the shared application, compromising the confidentiality and integrity of the session.
Affected products
- Qt: from 6.4.0 before 6.8.9; from 6.9.0 before 6.11.3 — fixed in 6.11.3, 6.8.9
How to fix
Upgrade to a fixed version: Qt 6.11.3, 6.8.9. Check the vendor advisory for mitigations.
References
- https://codereview.qt-project.org/c/qt/tqtc-qtvncserver/+/759160
- https://wiki.qt.io/List_of_known_vulnerabilities_in_Qt_products#CVE-2026-79680:
Get alerted when CVE-2026-79680 or the next vulnerability affects your stack