What’s Vulnerable › Vulnerabilities
CVE-2026-79708: Incorrect Authorization in GitLab
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-28
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 19.0 before 19.1.8, 19.2 before 19.2.6, and 19.3 before 19.3.2 that, under certain conditions could have allowed an authenticated user with developer permissions to execute a policy test pipeline on projects within their group and access protected CI/CD variables restricted to higher-privileged roles, due to insufficient scope validation.
Affected products
- GitLab: from 19.0.0 before 19.1.8; from 19.2.0 before 19.2.6; from 19.3.0 before 19.3.2 — fixed in 19.1.8, 19.2.6, 19.3.2
How to fix
Upgrade to a fixed version: GitLab 19.1.8, 19.2.6, 19.3.2. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-3-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/622477
- https://hackerone.com/reports/3873243
Get alerted when CVE-2026-79708 or the next vulnerability affects your stack