What’s Vulnerable › Vulnerabilities
CVE-2026-79770: Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-09-01
- Weakness: CWE-1333
Description
Nokogiri versions before 1.19.3 contain regular expression denial of service vulnerabilities in the CSS selector tokenizer affecting string-literal and identifier tokenization. Attackers can inject adversarial CSS selectors into methods like Node#css, Node#at_css, and Searchable#search to cause exponential regex backtracking and denial of service.
Affected products
- sparklemotion nokogiri: before 1.19.3 — fixed in 1.19.3
- Rubygems Nokogiri: before 1.19.3; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+187) — fixed in 1.19.3
How to fix
Upgrade to a fixed version: sparklemotion nokogiri 1.19.3; Rubygems Nokogiri 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-c4rq-3m3g-8wgx
- https://www.vulncheck.com/advisories/nokogiri-before-redos-via-css-selector-tokenizer
Get alerted when CVE-2026-79770 or the next vulnerability affects your stack