What’s Vulnerable › Vulnerabilities
CVE-2026-79771: Nokogiri before 1.19.3 Memory Leak via XSLT Transform
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-09-01
- Weakness: CWE-401
Description
Nokogiri versions before 1.19.3 contain a memory leak in the XSLT Stylesheet transform method when processing Ruby strings containing null bytes. Attackers can exploit this by passing attacker-controlled input with null bytes to transform parameters, causing heap allocations to leak and enabling denial of service against long-running processes.
Affected products
- sparklemotion nokogiri: before 1.19.3 — fixed in 1.19.3
- Rubygems Nokogiri: before 1.19.3; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+187) — fixed in 1.19.3
How to fix
Upgrade to a fixed version: sparklemotion nokogiri 1.19.3; Rubygems Nokogiri 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-v2fc-qm4h-8hqv
- https://www.vulncheck.com/advisories/nokogiri-before-memory-leak-via-xslt-transform
Get alerted when CVE-2026-79771 or the next vulnerability affects your stack