What’s Vulnerable › Vulnerabilities
CVE-2026-79777: rclone before v1.75.0 Information Disclosure via RC API
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-09-10
- Weakness: CWE-209
Description
rclone before v1.75.0 includes full Go stack traces in RC API error responses when panics occur. Attackers can trigger panics to leak internal file paths, module versions, goroutine states, and memory addresses.
Affected products
- rclone: before 1.75.0 — fixed in 1.75.0
How to fix
Upgrade to a fixed version: rclone 1.75.0. Check the vendor advisory for mitigations.
References
- https://github.com/rclone/rclone/security/advisories/GHSA-gwfq-86j8-7qhv
- https://www.vulncheck.com/advisories/rclone-before-information-disclosure-via-rc-api
- https://github.com/rclone/rclone/security/advisories/GHSA-gwfq-86j8-7qhv
Get alerted when CVE-2026-79777 or the next vulnerability affects your stack