What’s Vulnerable › Vulnerabilities
CVE-2026-80147: Lantronix Autonomous Out-of-Band Devices Stack-Based Buffer Overflow via mfc eeprom write
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-24
- Weakness: CWE-121
Description
Lantronix SLC8000/SLC9000 before firmware v9.7.0.2, EMG8500/EMG7500 before firmware v9.7.0.1, and all firmware versions of SLB882/SLCx-03/SLCx-02 contain a stack-based buffer overflow vulnerability that allows authenticated attackers to potentially execute arbitrary code by exploiting an undocumented mfc eeprom write command that copies unbounded user input into a bounded stack buffer before passing it to a system() call. Attackers can authenticate as any user to the terminal or CLI interface and supply an oversized input to trigger the overflow, potentially achieving complete loss of confidentiality, integrity, and availability on the affected device and impacting downstream serial-attached devices.
Affected products
- LANTRONIX EMG7500: before 9.7.0.1 — fixed in 9.7.0.1
- LANTRONIX EMG8500: before 9.7.0.1 — fixed in 9.7.0.1
- LANTRONIX SLB882: all versions
- LANTRONIX SLC8000: before 9.7.0.2 — fixed in 9.7.0.2
- LANTRONIX SLC9000: before 9.7.0.2 — fixed in 9.7.0.2
- LANTRONIX SLCx-02: all versions
- LANTRONIX SLCx-03: all versions
How to fix
Upgrade to a fixed version: LANTRONIX EMG7500 9.7.0.1; LANTRONIX EMG8500 9.7.0.1; LANTRONIX SLC8000 9.7.0.2; LANTRONIX SLC9000 9.7.0.2. Check the vendor advisory for mitigations.
References
- https://revrb.net/2026/09/21/revrb-lantern.html
- https://ts.lantronix.com/ftp/SLC9000/9.7.0.2R1/
- https://ts.lantronix.com/ftp/emg/EMG_7500/9.7.0.1R2/
- https://ts.lantronix.com/ftp/emg/EMG_8500/9.7.0.1R2/
- https://ts.lantronix.com/ftp/slc8000/9.7.0.2R1/
- https://www.vulncheck.com/advisories/lantronix-autonomous-out-of-band-devices-stack-based-buffer-overflow-via-mfc-eeprom-write
Get alerted when CVE-2026-80147 or the next vulnerability affects your stack