What’s Vulnerable › Vulnerabilities
CVE-2026-80148: Lantronix Autonomous Out-of-Band Devices WebSSH SSRF via Username Truncation
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-22 · updated 2026-09-26
- Weakness: CWE-918
Description
Lantronix SLC8000 before firmware v9.7.0.3, SLC9000 before firmware v9.7.0.2, EMG8500/EMG7500 before firmware v9.7.0.1, and all firmware versions of SLB882 contain a server-side request forgery vulnerability in the WebSSH/WebTelnet listener that allows unauthenticated attackers to cause the affected device to establish SSH connections to attacker-controlled endpoints. The custom shellinaboxd builds its SSH connection target using a snprintf call with user-supplied input; by supplying an overlong username string an attacker causes the device IP suffix to be truncated, redirecting the resulting connection to an arbitrary host. Attackers can use this capability to enumerate or communicate with internal network endpoints that would otherwise be inaccessible.
Affected products
- LANTRONIX EMG7500: before 9.7.0.1 — fixed in 9.7.0.1
- LANTRONIX EMG8500: before 9.7.0.1 — fixed in 9.7.0.1
- LANTRONIX SLB882: all versions
- LANTRONIX SLC8000: before 9.7.0.3 — fixed in 9.7.0.3
- LANTRONIX SLC9000: before 9.7.0.2 — fixed in 9.7.0.2
How to fix
Upgrade to a fixed version: LANTRONIX EMG7500 9.7.0.1; LANTRONIX EMG8500 9.7.0.1; LANTRONIX SLC8000 9.7.0.3; LANTRONIX SLC9000 9.7.0.2. Check the vendor advisory for mitigations.
References
- https://revrb.net/2026/09/21/revrb-lantern.html
- https://ts.lantronix.com/ftp/SLC9000/9.7.0.2R1/
- https://ts.lantronix.com/ftp/emg/EMG_7500/9.7.0.1R2/
- https://ts.lantronix.com/ftp/emg/EMG_8500/9.7.0.1R2/
- https://ts.lantronix.com/ftp/slc8000/9.7.0.3R3/
- https://www.vulncheck.com/advisories/lantronix-autonomous-out-of-band-devices-webssh-ssrf-via-username-truncation
Get alerted when CVE-2026-80148 or the next vulnerability affects your stack