What’s Vulnerable › Vulnerabilities
CVE-2026-80203: Grav before 1.0.18 Authentication Bypass via Scoped API Key
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-09-03
- Weakness: CWE-863
Description
The getgrav/grav-plugin-api plugin before 1.0.18 does not enforce API-key scope in the requireNotSuperTarget() function in UsersController.php across seven sensitive user-management endpoints. The check uses isSuperAdmin() on the acting account rather than verifying whether the specific API key carries super authority (via isSuperWithinScope()). As a result, an API key scoped below full super authority but belonging to a super-admin account can act against other super-admin accounts—disabling their 2FA, deleting their avatar, minting new API keys under their identity, or deleting their existing API keys.
Affected products
- getgrav grav: before 1.0.18 — fixed in 1.0.18
How to fix
Upgrade to a fixed version: getgrav grav 1.0.18. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-94q7-vrqr-cx5v
- https://www.vulncheck.com/advisories/grav-before-1.0.18-authentication-bypass-via-scoped-api-key
Get alerted when CVE-2026-80203 or the next vulnerability affects your stack