What’s Vulnerable › Vulnerabilities
CVE-2026-80339: Payment Plugins for Stripe WooCommerce < 4.0.12 - Unauthenticated Customer PII Disclosure via order-pay
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-09
- Weakness: CWE-200
Description
The Payment Plugins for Stripe WooCommerce WordPress plugin before 4.0.12 does not validate the order key before adding order data to the JavaScript configuration it outputs on the front end, allowing unauthenticated users to obtain the billing details of any order, together with the secret that gates access to it, by iterating sequential order identifiers.
Affected products
- Payment Plugins for Stripe WooCommerce: from 4.0.0 before 4.0.12 — fixed in 4.0.12
How to fix
Upgrade to a fixed version: Payment Plugins for Stripe WooCommerce 4.0.12. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-80339 or the next vulnerability affects your stack