What’s Vulnerable › Vulnerabilities
CVE-2026-80340: Payment Plugins for PayPal WooCommerce < 2.0.26 - Unauthenticated Customer PII Disclosure via order-pay
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-09-09
- Weakness: CWE-200
Description
The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.26 does not validate the order key before adding order data to the JavaScript configuration it outputs on the front end, allowing unauthenticated users to obtain the secret that gates access to any order and, through it, that customer's billing and shipping details, by iterating sequential order identifiers.
Affected products
- Payment Plugins for PayPal WooCommerce: from 1.0.0 before 2.0.26 — fixed in 2.0.26
How to fix
Upgrade to a fixed version: Payment Plugins for PayPal WooCommerce 2.0.26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-80340 or the next vulnerability affects your stack