What’s Vulnerable › Vulnerabilities
CVE-2026-80342: Payment Plugins for PayPal WooCommerce < 2.0.27 - Unauthenticated Payment Hijacking via Unvalidated PayPal Order ID
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-639
Description
The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.27 does not verify that a PayPal order supplied in a payment request belongs to the WooCommerce order being paid unless that PayPal order has already been completed, allowing unauthenticated attackers to have another buyer's approved but uncaptured payment captured against an order of their own.
Affected products
- Payment Plugins for PayPal WooCommerce: before 2.0.27 — fixed in 2.0.27
How to fix
Upgrade to a fixed version: Payment Plugins for PayPal WooCommerce 2.0.27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-80342 or the next vulnerability affects your stack