What’s Vulnerable › Vulnerabilities
CVE-2026-80465
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-03 · updated 2026-10-26
- Weakness: CWE-347
Description
A vulnerability has been identified in Mendix SAML (Mendix 10 compatible) (All versions < V4.2.4), Mendix SAML (Mendix 11 compatible) (All versions < V4.2.4), Mendix SAML (Mendix 9.24 compatible) (All versions < V3.6.29). Affected versions of the module do not properly validate the SAML response signature. This could allow unauthenticated remote attackers to hijack an account (session) in specific SSO configurations.
Affected products
- Siemens Mendix SAML (Mendix 10 compatible): before V4.2.3 — fixed in V4.2.3
- Siemens Mendix SAML (Mendix 11 compatible): before V4.2.3 — fixed in V4.2.3
- Siemens Mendix SAML (Mendix 9.24 compatible): before V3.6.27 — fixed in V3.6.27
How to fix
Upgrade to a fixed version: Siemens Mendix SAML (Mendix 10 compatible) V4.2.3; Siemens Mendix SAML (Mendix 11 compatible) V4.2.3; Siemens Mendix SAML (Mendix 9.24 compatible) V3.6.27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-80465 or the next vulnerability affects your stack