What’s Vulnerable › Vulnerabilities
CVE-2026-8056: Parameter Injection Vulnerability in API Graph Execution Engine
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-94
Description
IBM Langflow OSS 1.0.0 through 1.10.0 allows authenticated users to override component parameters at runtime via the API. A critical security flaw exists in the parameter filtering mechanism within the `apply_tweaks()` function.
Affected products
- IBM Langflow OSS: from 1.0.0 before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.10.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8056 or the next vulnerability affects your stack