What’s Vulnerable › Vulnerabilities
CVE-2026-80565: crypto: qce - fix error path in devm_qce_register_algs
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-27
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: qce - fix error path in devm_qce_register_algs If ops->register_algs() fails, the error path repeatedly calls the same ops->unregister_algs() from the failed registration. Use the loop index to unregister the previously registered algorithms instead.
Affected products
- Linux kernel: from 5.10.235 before 5.10.266; from 5.15.179 before 5.15.217; from 6.1.129 before 6.1.184; from 6.6.78 before 6.6.153; from 6.12.14 before 6.12.105; from 5.4.291 before 5.5 — fixed in 5.10.266, 5.15.217, 5.5, 6.1.184, 6.12.105, 6.14
How to fix
Upgrade to a fixed version: Linux kernel 5.10.266, 5.15.217, 5.5, 6.1.184. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1ece8e16c085e8cd60ecbdb641269aaa53d31da4
- https://git.kernel.org/stable/c/4e88b4fda48282f3fd504b4d4f5d2d4f996b76ce
- https://git.kernel.org/stable/c/9c75402286409f5e1a75e4a445555c84066f89db
- https://git.kernel.org/stable/c/a134e4b8102c077286818ee112b9f925db613d4c
- https://git.kernel.org/stable/c/c7dc487aade12c692add3221673c9bdf32dc24f5
- https://git.kernel.org/stable/c/dbca8b798caf47fb2799a26dd09c9ad66305883d
- https://git.kernel.org/stable/c/de52c713d21806b93b00a6074056b57aec4f8919
- https://git.kernel.org/stable/c/fef187c6194d67395182d58169dd14ba631f1b41
Get alerted when CVE-2026-80565 or the next vulnerability affects your stack