What’s Vulnerable › Vulnerabilities
CVE-2026-80609: qede: fix out-of-bounds check for cqe->len_list[]
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-10-16
Description
In the Linux kernel, the following vulnerability has been resolved: qede: fix out-of-bounds check for cqe->len_list[] Move index check before element access.
Affected products
- Linux kernel: from 5.15.197 before 5.15.212; from 6.1.159 before 6.1.178; from 6.6.118 before 6.6.145; from 6.12.60 before 6.12.97; from 6.17.10 before 6.18; 6.18 — fixed in 5.15.212, 6.1.178, 6.12.97, 6.18, 6.6.145, 7.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.212, 6.1.178, 6.12.97, 6.18. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1aacefd074b5dcc99b8dbcd73e1c963ed5010110
- https://git.kernel.org/stable/c/6d203bdd227fca1787f8a80cf84b990936633c5a
- https://git.kernel.org/stable/c/6d46ab395803f162cdc50e8d346e5f1a4e766771
- https://git.kernel.org/stable/c/b17751a2ebc4aef3ce6be6f71ee8df92bf5ddfcd
- https://git.kernel.org/stable/c/bd3a6a083b408e96437dbd86ff543ba9ec3a788b
- https://git.kernel.org/stable/c/e30af53dca803893a29eb3bbe0539752ba435410
- https://git.kernel.org/stable/c/f9ba47fce5932c15891c89c60e76dfaca919cb8d
Get alerted when CVE-2026-80609 or the next vulnerability affects your stack