What’s Vulnerable › Vulnerabilities
CVE-2026-8089: weMail < 2.1.3 - Reflected Cross-Site Scripting
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The weMail: Email Marketing, Email Automation, Newsletters, Subscribers & Email Optins for WooCommerce WordPress plugin before 2.1.3 does not properly escape a user-supplied parameter before reflecting it into an HTML attribute on a non-nonce-protected AJAX response, allowing unauthenticated attackers to deliver Reflected Cross-Site Scripting against any authenticated user (including administrators) via a crafted URL.
Affected products
- weMail: Email Marketing, Email Automation, Newsletters, Subscribers & Email Optins for WooCommerce: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: weMail: Email Marketing, Email Automation, Newsletters, Subscribers & Email Optins for WooCommerce 2.1.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-8089 or the next vulnerability affects your stack