What’s Vulnerable › Vulnerabilities
CVE-2026-81026: MasterStudy LMS < 3.7.40 - Unauthenticated Payment Bypass via PayPal IPN
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-29 · updated 2026-08-31
- Weakness: CWE-284
Description
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.7.40 does not verify the amount, receiver, currency or status of a payment notification before marking the corresponding order completed, allowing unauthenticated users to complete full-price orders and gain access to paid content by paying only a token amount.
Affected products
- MasterStudy LMS WordPress Plugin: before 3.7.40 — fixed in 3.7.40
How to fix
Upgrade to a fixed version: MasterStudy LMS WordPress Plugin 3.7.40. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-81026 or the next vulnerability affects your stack